VDX 1台分のコンフィグを確認したい

VDX 4台で 1つの巨大なスイッチを構成するために、ロジカル・シャーシ対応 VCS を組んでいますが。

Cisco と同じように # show running-config コマンドは存在するものの、いざ実行すると 4台分のコンフィグが全て表示されるため、とんでもない量になってしまいます。

それで、? を打って、暗中模索しながら # show running-config rbridge-id <ID> というそれっぽいコマンドを発見したので、早速実行。

Principal# show running-config rbridge-id <ID>Raw Code(S)Raw Code(T)
vdx01# show running-config rbridge-id 3
rbridge-id 3
 switch-attributes chassis-name VDX6740T
 switch-attributes host-name vdx03
 vrf mgmt-vrf
  address-family ipv4 unicast
   ip route 0.0.0.0/0 10.10.10.1
  !
  address-family ipv6 unicast
  !
 !
 system-monitor fan threshold marginal-threshold 1 down-threshold 2
 system-monitor fan alert state removed action raslog
 ・・・
 no protocol vrrp
 no protocol vrrp-extended
 hardware-profile tcam default
 hardware-profile route-table default
 clock timezone Asia/Tokyo
 ssh server key rsa 2048
 ssh server key ecdsa 256
 ssh server key dsa
 fcoe
  fcoe-enodes 0
 !
!

む。。ポート番号も出てこないし、これじゃなかったんですね。

特定 Rbridge ID のコンフィグ確認

データセンター向けの高性能、低レイテンシを売りにしている VDX に特定 VDX のコンフィグを確認する方法が無いわけがないと思い、さらに探してみたところ、# show rbridge-running-config というコマンドがありました。

上記のコマンドを実行することで、特定 Rbridge ID のコンフィグを確認することができます。

この例では、プリンシパルスイッチ vdx01 にログインした状態で、3番目の VDX である vdx03 (rbridge-id 3) のコンフィグを確認します。

# show rbridge-running-config rbridge-id <ID>Raw Code(S)Raw Code(T)
vdx01# show rbridge-running-config rbridge-id 3
diag post rbridge-id 3
 enable
 
・・・

switch-attributes 3
 chassis-name VDX6740T
 host-name vdx03
!
・・・
!
interface Vlan 1
!
interface Vlan 100
 name 192.168.100.0/24
!
interface Vlan 101
 name 192.168.101.0/24
!
・・・
!
rbridge-id 3
 switch-attributes chassis-name VDX6740T
 switch-attributes host-name vdx03
 vrf mgmt-vrf
  address-family ipv4 unicast
   ip route 0.0.0.0/0 10.10.10.1
  !
  address-family ipv6 unicast
  !
  ・・・
!
・・・
!
interface TenGigabitEthernet 3/0/1
 fabric isl enable
 fabric trunk enable
 no shutdown
!
interface TenGigabitEthernet 3/0/2
 fabric isl enable
 fabric trunk enable
 no shutdown
!
interface TenGigabitEthernet 3/0/3
 fabric isl enable
 fabric trunk enable
 no shutdown
!
・・・
!
interface TenGigabitEthernet 3/0/48
 fabric isl enable
 fabric trunk enable
 no shutdown
!
・・・

以上、VDX 特定 Rbridge ID のコンフィグ確認方法 でした。